Cómo corregir errores de archivo Pluggable.php en WordPress

¿Está viendo un error de archivo pluggable.php en su sitio de WordPress? A veces, cuando agrega un fragmento de código en su sitio o activa un nuevo complemento, puede obtener el error de archivo pluggable.php. En este artículo, le mostraremos cómo corregir los errores del archivo pluggable.php en WordPress.

Corregir errores en el archivo pluggable.php en WordPress

¿Cuándo y por qué aparecen errores Pluggable.php?

WordPress permite a los usuarios y complementos anular ciertas funciones básicas. Estas funciones se encuentran en el archivo pluggable.php.

Si un complemento de WordPress o un fragmento de código personalizado no puede manejar correctamente una de estas funciones, verá un error como este:

Advertencia: No se puede modificar la información del encabezado: los encabezados ya han sido enviados por (la salida comenzó en /home/username/demosite/wp-content/themes/mytheme/functions.php:1035) en /home/username/demosite/wp-includes/pluggable.php en la línea 1179

Ejemplo de un error en WordPress que menciona el archivo pluggable.php

A veces, es posible que pueda continuar trabajando en su sitio con este u otro error que aún aparece en el área de administración.

Error en el área de administración de WordPress

Dicho esto, echemos un vistazo a cómo solucionar fácilmente el error del archivo pluggable.php en WordPress.

Solucionar errores de archivo Pluggable.php en WordPress

El archivo pluggable.php es un archivo principal de WordPress. Nunca es una buena idea editar el archivo principal de WordPress como primera opción, incluso cuando hay un error que lo señala.

Lo más probable es que el error provenga de una ubicación diferente.

Para corregir cualquier error que mencione el archivo pluggable.php, solo mire la primera ubicación mencionada en el error.

Advertencia: No se puede modificar la información del encabezado: los encabezados ya han sido enviados por (la salida comenzó en /home/username/demosite/wp-content/themes/mytheme/functions.php:1035) en /home/username/demosite/wp-includes/pluggable.php en la línea 1179

En el ejemplo anterior, el error se encuentra en el archivo functions.php del tema en la línea 1035.

Esto significa que debe editar el archivo functions.php de su tema y cambiar o eliminar el código que causa este error.

A veces, el error de los encabezados ya enviados se debe a un espacio adicional después de cerrar la etiqueta php?>, Por lo que puede eliminarlo y solucionará el problema.

Echemos un vistazo a otro ejemplo:

Advertencia: No se puede modificar la información del encabezado: los encabezados ya enviados por (la salida comenzó en /home/username/demosite/wp-content/plugins/some-plugin-name/some-plugin.php:144) en /home/username/demosite/wp-includes/pluggable.php en la línea 1090

Este mensaje de error apunta a un complemento en su sitio de WordPress que está causando el error. Simplemente puede desactivar el complemento y notificar al autor del complemento sobre el error.

En casi todos los casos, los errores que mencionan el archivo pluggable.php no son causados ​​por el archivo en sí.

Estos errores generalmente son causados ​​por un fragmento de código personalizado que agregó al archivo functions.php, o un complemento mal codificado, o incluso su tema de WordPress.

Simplemente eliminar o editar el código o desactivar el complemento hará que el error desaparezca.

¿Aún no puede averiguar qué está causando estos errores?

Siga las instrucciones de nuestra guía paso a paso para solucionar errores de WordPress. Le ayudará a descubrir la causa del error y cómo solucionarlo rápidamente.

Esperamos que este artículo lo haya ayudado a resolver los errores del archivo pluggable.php en WordPress. También puede marcar nuestra lista de errores más comunes de WordPress y cómo solucionarlos.

Si le gustó este artículo, suscríbase a nuestro canal de YouTube para tutoriales en video de WordPress. También puedes encontrarnos en Twitter y Facebook.

Publicaciones relacionadas

Botón volver arriba